aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f667fb0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.5)
+project(twtxtc C)
+
+set(CMAKE_BUILD_TYPE Release)
+set(CMAKE_C_STANDARD 11)
+
+if (MSVC)
+ # meh
+ add_definitions(-D_CRT_SECURE_NO_WARNINGS)
+endif (MSVC)
+
+add_executable(twtxtc cJSON/cJSON.c cJSON/cJSON_Utils.c twtxt.c)